Jump to content

Geometries missing when imported into GOM


Recommended Posts

Recently while working on step file from customer I encountered something never seen before: when I import the CAD directly as new part it shows just 1 model but if I import it to clip board first there're actually 2 models (overlapping with slight difference at one end).



This behaves same in 2020 or 2021 (HF3). So what makes the software to decide keeping 003999 1 but removing 003999 automatically when "new part" is selected? Actually during the import I can see both shown in clipboard quickly in one second then when new part was created only 1 model kept (003999 1 in this case). Anyone else has seen something similar? Better someone can help explain, thanks.


Ray Xing

Xpert3D Metrology


Link to comment
Share on other sites

Dear Ray,
By importing CAD Data you have the option to import all CAD data or only visible CAD data. In Software 2020 this decision is done at hand of how to import, see during import as part the "Relates to" tab, is the 003999 set to visible or not?

In GOM Software 2021 you can explicitly choose what is to be imported by the Import template for CAD Data: e.g. visible surfaces or additionally invisible surfaces: 
Importing CAD data to the clipboard is to be used to e.g. to clean up the CAD file if there are bodies that are not required or to separate CAD groups by dragging them into different parts. If you are not sure which data is contained in the CAD file I'd recommend to import to the clipboard first and select the invisible elements for import, too.
If you have different experiences on the import functionality with your CAD data please get in contact with support@gom.com.

BR Christine

Link to comment
Share on other sites

Hi, this is hard to answer with the given information

  • If you directly import to a Part only the visible bodies will be moved. According to your screenshot, both bodies are visible. Did you change that, or have they been visible directly after clipboard import
  • In the part, it is normal that only one CAD is shown, even if it consists of several bodies. You can use "EDIT CAD" (i.e. use the pencil right to the CAD in the explorer) to show what it is composed of. Do you see both bodies here?
  • If none of this answers it, you can try to move both bodies from the clipboard to different parts. What happens then?
  • If there really is a problem with this file, feel free to send it to the GOM Support and we'll have a look at it.

Hope this helps!

Link to comment
Share on other sites

Thanks for both replies. I've tried following with your suggestions:

-- In 2020, I imported CAD directly and it shows only 1 model is set to visible


Now even if I set both visible


After click ok, still only the originally visible model is imported


I even tried making the original one invisible and the other one visible but it still only imports the same model. If I import the CAD into clipboard then I can freely choose whatever I want for the part or even put them in different part so the clipboard method always works.

Now in 2021, I first import it with following settings (turn on invisible elements):


But still only 1 model imported after I selected "new part":


If I use clipboard method then it will always work same as 2020.

 So any more thoughts?



Link to comment
Share on other sites


  • Create New...